Blackhold

Recuperar instalación a medias

Posted on juliol 22nd, 2014 by Blackhold

Ya es la segunda vez que me encuentro que un ubuntu se ha quedado a medias con una instalación y no hay forma de arrancar. La solución es montar la partición y seguir con la instalación.

Lo primero es arrancar el equipo con una livecd y montar la partición donde está el sistema operativo.

Abrimos una terminal y nos ponemos como root ejecutando “sudo su”.

# mkdir /mnt/hd && mount -t ext3 /dev/sda1 /mnt/hd

Read more on “Recuperar instalación a medias” »

Aspell: ¿cómo hacer que funcione la corrección ortográfica?

Posted on juny 26th, 2014 by Blackhold

Siempre que te pones a escribir un documento y tienes que presentarlo de forma un poco bonita, lo importante es que tenga el mínimo de faltas de ortografía posibles.
La pega es que a veces con GNU/Linux la instalación de los diccionarios es un poco tediosa y no acaba de funcionar muy bien, el problema claro está, en el usuario que no sabe que lo que hay detrás de los diccionarios es aspell.

Para instalar los diccionarios (por ejemplo catalán y castellano)

root@carboni:/home/laura# apt-get install aspell-ca aspell-es

Pero a partir de aquí tienes que decirle a aspell que le has cargado dos nuevos diccionarios

root@carboni:/home/laura# aspell-autobuildhash

Y para ver los diccionarios que tienes instalados

root@carboni:/home/laura# aspell dicts
ca
ca-general
ca-valencia
es

Y hasta aquí el luserpost de hoy. Al menos sin errores ortográficos, que no errores gramaticales ;P

Priorizando paquetes en mikrotik – Queues

Posted on juny 26th, 2014 by Blackhold

Un scriptillo para tenerlo a mano :P

# CAPA8.NET
# SCRIPT CREATION: 2014-06-26
# AUTHORS: CRAEM + BLACKHOLD
#
## MANGLE SIP # PRIORITY 1
/ip firewall mangle add action=mark-connection chain=prerouting comment=RTP dst-port=10000-20000 new-connection-mark=SIP protocol=udp
/ip firewall mangle add action=mark-connection chain=postrouting comment=RTP dst-port=10000-20000 new-connection-mark=SIP protocol=udp
/ip firewall mangle add action=mark-connection chain=prerouting comment=SIP dst-port=5060 new-connection-mark=SIP protocol=udp
/ip firewall mangle add action=mark-connection chain=postrouting comment=SIP dst-port=5060 new-connection-mark=SIP protocol=udp
#
# MANGLE DNS SSH WINBOX ICMP IGMP SNP SNMP TELNET IRC # PRIORITY 2
/ip firewall mangle add action=mark-connection chain=prerouting comment=DNS dst-port=53 new-connection-mark=DNS protocol=udp
/ip firewall mangle add action=mark-connection chain=postrouting comment=DNS dst-port=53 new-connection-mark=DNS protocol=udp
/ip firewall mangle add action=mark-connection chain=prerouting comment=DNS dst-port=53 new-connection-mark=DNS protocol=tcp
/ip firewall mangle add action=mark-connection chain=postrouting comment=DNS dst-port=53 new-connection-mark=DNS protocol=tcp
/ip firewall mangle add action=mark-connection chain=prerouting comment=BGP dst-port=179 new-connection-mark=BGP protocol=tcp
/ip firewall mangle add action=mark-connection chain=postrouting comment=BGP dst-port=179 new-connection-mark=BGP protocol=tcp
/ip firewall mangle add action=mark-connection chain=prerouting comment=WINBOX dst-port=8291 new-connection-mark=WINBOX protocol=tcp
/ip firewall mangle add action=mark-connection chain=postrouting comment=WINBOX dst-port=8291 new-connection-mark=WINBOX protocol=tcp
/ip firewall mangle add action=mark-connection chain=prerouting comment=SSH dst-port=22 new-connection-mark=SSH protocol=tcp
/ip firewall mangle add action=mark-connection chain=postrouting comment=SSH dst-port=22 new-connection-mark=SSH protocol=tcp
/ip firewall mangle add action=mark-connection chain=prerouting comment=ICMP dst-port=1 new-connection-mark=ICMP protocol=tcp
/ip firewall mangle add action=mark-connection chain=postrouting comment=ICMP dst-port=1 new-connection-mark=ICMP protocol=tcp
/ip firewall mangle add action=mark-connection chain=prerouting comment=ICMP dst-port=58 new-connection-mark=ICMP protocol=tcp
/ip firewall mangle add action=mark-connection chain=postrouting comment=ICMP dst-port=58 new-connection-mark=ICMP protocol=tcp
/ip firewall mangle add action=mark-connection chain=prerouting comment=IGMP dst-port=2 new-connection-mark=IGMP protocol=tcp
/ip firewall mangle add action=mark-connection chain=postrouting comment=IGMP dst-port=2 new-connection-mark=IGMP protocol=tcp
/ip firewall mangle add action=mark-connection chain=prerouting comment=SNP dst-port=109 new-connection-mark=SNP protocol=tcp
/ip firewall mangle add action=mark-connection chain=postrouting comment=SNP dst-port=109 new-connection-mark=SNP protocol=tcp
/ip firewall mangle add action=mark-connection chain=prerouting comment=SNMP dst-port=161 new-connection-mark=SNMP protocol=tcp
/ip firewall mangle add action=mark-connection chain=postrouting comment=SNMP dst-port=161 new-connection-mark=SNMP protocol=tcp
/ip firewall mangle add action=mark-connection chain=prerouting comment=SNMP dst-port=161 new-connection-mark=SNMP protocol=udp
/ip firewall mangle add action=mark-connection chain=postrouting comment=SNMP dst-port=161 new-connection-mark=SNMP protocol=udp
/ip firewall mangle add action=mark-connection chain=prerouting comment=SNMP dst-port=162 new-connection-mark=SNMP protocol=tcp
/ip firewall mangle add action=mark-connection chain=postrouting comment=SNMP dst-port=162 new-connection-mark=SNMP protocol=tcp
/ip firewall mangle add action=mark-connection chain=prerouting comment=SNMP dst-port=162 new-connection-mark=SNMP protocol=udp
/ip firewall mangle add action=mark-connection chain=postrouting comment=SNMP dst-port=162 new-connection-mark=SNMP protocol=udp
/ip firewall mangle add action=mark-connection chain=prerouting comment=TELNET dst-port=23 new-connection-mark=TELNET protocol=tcp
/ip firewall mangle add action=mark-connection chain=postrouting comment=TELNET dst-port=23 new-connection-mark=TELNET protocol=tcp
/ip firewall mangle add action=mark-connection chain=prerouting comment=IRC dst-port=6665 new-connection-mark=IRC protocol=tcp
/ip firewall mangle add action=mark-connection chain=postrouting comment=IRC dst-port=6665 new-connection-mark=IRC protocol=tcp
/ip firewall mangle add action=mark-connection chain=prerouting comment=IRC dst-port=6666 new-connection-mark=IRC protocol=tcp
/ip firewall mangle add action=mark-connection chain=postrouting comment=IRC dst-port=6666 new-connection-mark=IRC protocol=tcp
/ip firewall mangle add action=mark-connection chain=prerouting comment=IRC dst-port=6667 new-connection-mark=IRC protocol=tcp
/ip firewall mangle add action=mark-connection chain=postrouting comment=IRC dst-port=6667 new-connection-mark=IRC protocol=tcp
/ip firewall mangle add action=mark-connection chain=prerouting comment=IRC dst-port=6697 new-connection-mark=IRC protocol=tcp
/ip firewall mangle add action=mark-connection chain=postrouting comment=IRC dst-port=6697 new-connection-mark=IRC protocol=tcp
#
# MANGLE HTTP HTTPS PROXY # PRIORITY 3
/ip firewall mangle add action=mark-connection chain=prerouting comment=HTTP dst-port=80 new-connection-mark=HTTP protocol=tcp
/ip firewall mangle add action=mark-connection chain=postrouting comment=HTTP dst-port=80 new-connection-mark=HTTP protocol=tcp
/ip firewall mangle add action=mark-connection chain=prerouting comment=HTTPS dst-port=443 new-connection-mark=HTTP protocol=tcp
/ip firewall mangle add action=mark-connection chain=postrouting comment=HTTPS dst-port=443 new-connection-mark=HTTP protocol=tcp
/ip firewall mangle add action=mark-connection chain=prerouting comment=PROXY dst-port=3128 new-connection-mark=PROXY protocol=tcp
/ip firewall mangle add action=mark-connection chain=postrouting comment=PROXY dst-port=3128 new-connection-mark=PROXY protocol=tcp
#
#
# MANGLE MARK PRIORITY 1 (SIP)
/ip firewall mangle add action=mark-packet chain=prerouting comment=SIP connection-mark=SIP new-packet-mark=LEVEL1 passthrough=no
/ip firewall mangle add action=mark-packet chain=postrouting comment=SIP connection-mark=SIP new-packet-mark=LEVEL1 passthrough=no
#
# MANGLE MARK PRIORITY 2
/ip firewall mangle add action=mark-packet chain=prerouting comment=DNS connection-mark=DNS new-packet-mark=LEVEL2 passthrough=no
/ip firewall mangle add action=mark-packet chain=postrouting comment=DNS connection-mark=DNS new-packet-mark=LEVEL2 passthrough=no
/ip firewall mangle add action=mark-packet chain=prerouting comment=BGP connection-mark=BGP new-packet-mark=LEVEL2 passthrough=no
/ip firewall mangle add action=mark-packet chain=postrouting comment=BGP connection-mark=BGP new-packet-mark=LEVEL2 passthrough=no
/ip firewall mangle add action=mark-packet chain=prerouting comment=WINBOX connection-mark=WINBOX new-packet-mark=LEVEL2 passthrough=no
/ip firewall mangle add action=mark-packet chain=postrouting comment=WINBOX connection-mark=WINBOX new-packet-mark=LEVEL2 passthrough=no
/ip firewall mangle add action=mark-packet chain=prerouting comment=SSH connection-mark=SSH new-packet-mark=LEVEL2 passthrough=no
/ip firewall mangle add action=mark-packet chain=postrouting comment=SSH connection-mark=SSH new-packet-mark=LEVEL2 passthrough=no
/ip firewall mangle add action=mark-packet chain=prerouting comment=ICMP connection-mark=ICMP new-packet-mark=LEVEL2 passthrough=no
/ip firewall mangle add action=mark-packet chain=postrouting comment=ICMP connection-mark=ICMP new-packet-mark=LEVEL2 passthrough=no
/ip firewall mangle add action=mark-packet chain=prerouting comment=IGMP connection-mark=IGMP new-packet-mark=LEVEL2 passthrough=no
/ip firewall mangle add action=mark-packet chain=postrouting comment=IGMP connection-mark=IGMP new-packet-mark=LEVEL2 passthrough=no
/ip firewall mangle add action=mark-packet chain=prerouting comment=SNP connection-mark=SNP new-packet-mark=LEVEL2 passthrough=no
/ip firewall mangle add action=mark-packet chain=postrouting comment=SNP connection-mark=SNP new-packet-mark=LEVEL2 passthrough=no
/ip firewall mangle add action=mark-packet chain=prerouting comment=SNMP connection-mark=SNMP new-packet-mark=LEVEL2 passthrough=no
/ip firewall mangle add action=mark-packet chain=postrouting comment=SNMP connection-mark=SNMP new-packet-mark=LEVEL2 passthrough=no
/ip firewall mangle add action=mark-packet chain=prerouting comment=TELNET connection-mark=TELNET new-packet-mark=LEVEL2 passthrough=no
/ip firewall mangle add action=mark-packet chain=postrouting comment=TELNET connection-mark=TELNET new-packet-mark=LEVEL2 passthrough=no
/ip firewall mangle add action=mark-packet chain=prerouting comment=IRC connection-mark=IRC new-packet-mark=LEVEL2 passthrough=no
/ip firewall mangle add action=mark-packet chain=postrouting comment=IRC connection-mark=IRC new-packet-mark=LEVEL2 passthrough=no
#
# MANGLE MARK PRIORITY 3
/ip firewall mangle add action=mark-packet chain=prerouting comment=HTTP connection-mark=HTTP new-packet-mark=LEVEL3 passthrough=no
/ip firewall mangle add action=mark-packet chain=postrouting comment=HTTP connection-mark=HTTP new-packet-mark=LEVEL3 passthrough=no
/ip firewall mangle add action=mark-packet chain=prerouting comment=PROXY connection-mark=PROXY new-packet-mark=LEVEL3 passthrough=no
/ip firewall mangle add action=mark-packet chain=postrouting comment=PROXY connection-mark=PROXY new-packet-mark=LEVEL3 passthrough=no
#
#
# QUEUES
/queue tree add name=LEVEL1 packet-mark=LEVEL1 parent=global-total priority=1 queue=default
/queue tree add name=LEVEL2 packet-mark=LEVEL2 parent=global-total priority=2 queue=default
/queue tree add name=LEVEL3 packet-mark=LEVEL3 parent=global-total priority=3 queue=default
/queue tree add name=LEVEL4 packet-mark=LEVEL4 parent=global-total priority=4 queue=default
#
:log info "Script created by craem + blackhold - capa8.net ::: thanks for using it!" 
/

En algunas RB no está el global-total, pero está global

# QUEUES
/queue tree add name=LEVEL1 packet-mark=LEVEL1 parent=global priority=1 queue=default
/queue tree add name=LEVEL2 packet-mark=LEVEL2 parent=global priority=2 queue=default
/queue tree add name=LEVEL3 packet-mark=LEVEL3 parent=global priority=3 queue=default
/queue tree add name=LEVEL4 packet-mark=LEVEL4 parent=global priority=4 queue=default
#
:log info "Script created by craem + blackhold - capa8.net ::: thanks for using it!" 
/

IPSEC

/ip firewall mangle add action=mark-connection chain=prerouting comment=IPSEC dst-port=50 new-connection-mark=IPSEC protocol=udp
/ip firewall mangle add action=mark-connection chain=postrouting comment=IPSEC dst-port=50 new-connection-mark=IPSEC protocol=udp
/ip firewall mangle add action=mark-connection chain=prerouting comment=IPSEC dst-port=51 new-connection-mark=IPSEC protocol=udp
/ip firewall mangle add action=mark-connection chain=postrouting comment=IPSEC dst-port=51 new-connection-mark=IPSEC protocol=udp
/ip firewall mangle add action=mark-connection chain=prerouting comment=IPSEC dst-port=500 new-connection-mark=IPSEC protocol=udp
/ip firewall mangle add action=mark-connection chain=postrouting comment=IPSEC dst-port=500 new-connection-mark=IPSEC protocol=udp
/ip firewall mangle add action=mark-connection chain=prerouting comment=IPSEC dst-port=500 new-connection-mark=IPSEC protocol=tcp
/ip firewall mangle add action=mark-connection chain=postrouting comment=IPSEC dst-port=500 new-connection-mark=IPSEC protocol=tcp
/ip firewall mangle add action=mark-connection chain=prerouting comment=IPSEC dst-port=4500 new-connection-mark=IPSEC protocol=udp
/ip firewall mangle add action=mark-connection chain=postrouting comment=IPSEC dst-port=4500 new-connection-mark=IPSEC protocol=udp
/ip firewall mangle add action=mark-connection chain=prerouting comment=IPSEC dst-port=4500 new-connection-mark=IPSEC protocol=tcp
/ip firewall mangle add action=mark-connection chain=postrouting comment=IPSEC dst-port=4500 new-connection-mark=IPSEC protocol=tcp


/ip firewall mangle add action=mark-packet chain=prerouting comment=IPSEC connection-mark=IPSEC new-packet-mark=LEVEL2 passthrough=no
/ip firewall mangle add action=mark-packet chain=postrouting comment=IPSEC connection-mark=IPSEC new-packet-mark=LEVEL2 passthrough=no

MOAR

Thinkpad X230 Debian Jessie

Posted on juny 18th, 2014 by Blackhold

Pues tras 4 años y medio con el X200, ahora cae un nuevo portátil, la primera impresión de los lusers que tengo alrededor es que es idéntico al otro, pero para los usuarios thinkpaderos, la cosa cambia un poquito.

Una de las cosas que mas nos preocupa a los thinkpadfanboys es el cambio de teclado, cabe decir que el del x230 va bastante bien y el tecleo es muy similar al de sus antecesores, incluso diría que un poquito mejor, la cosa que si que hace que me pierda un poco es que han cambiado la disposición de algunas teclas (ya no hay 2 niveles de teclas de función, sino sólo uno), pero vamos, algo que te puedes acostumbrar en algunas semanas.
Otra cosa era la robustez, sigue siendo igual de robusto que sus antecesores, además de que las bisagras son un poco mas gruesas.

DSC_0841

Read more on “Thinkpad X230 Debian Jessie” »

Borrar ficheros mas antiguos de 30 días

Posted on juny 15th, 2014 by Blackhold

Find es una interesante herramienta que permite pasarle multitud de argumentos, incluso otro que permite ejecutar otro comando.
Nos encontramos con el directorio data de mailman en los que hay mogollón de mensajes retenidos a la espera de moderación y queremos hacer un poco de limpieza. Así que vamos a borrar los retenidos mas viejos de 30 días.

tesla:/var/lib/mailman/data# find ./*.pck -mtime +30 -exec rm {} \;

-mtime es para indicarle los ficheros mas antiguos de x días

Lax’n’busto – No és massa tard

Posted on juny 4th, 2014 by Blackhold

Lax’n’busto – No és massa tard

Read more on “Lax’n’busto – No és massa tard” »

Stream de Icecast 2.4.0 con webm

Posted on juny 1st, 2014 by Blackhold

Webm es el nuevo protocolo estándard de stream de vídeo compatible con html5.

El día 4 de Mayo salió la nueva release de este software de streaming y una de las novedades es el soporte de webm.

Vamos a instalar icecast 2.4.0 en una debian 7:

Instalamos primero algunas dependencias

root@capa8-icecast:/usr/local# apt-get install build-essential libxslt1-dev libvorbis-dev curl

Read more on “Stream de Icecast 2.4.0 con webm” »

Aprende a apreciar el esfuerzo

Posted on maig 30th, 2014 by Blackhold

Un joven fue a solicitar un puesto importante en una empresa grande. Pasó la entrevista inicial e iba a conocer al director para la entrevista final. El director vio su CV, era excelente. Y le preguntó: ” ¿Recibió alguna beca en la escuela?” el joven respondió “no”.
“¿Fue tu padre quien pagó tus estudios? ”
” Si.”-respondió.
“¿Dónde trabaja tu padre? ”
“Mi padre hace trabajos de herreria.”
El director pidió al joven que le mostrara sus manos .
El joven mostró un par de manos suaves y perfectas.
“¿Alguna vez has ayudado a tu padre en su trabajo? ”
“Nunca, mis padres siempre quisieron que estudiara y leyera más libros. Además, él puede hacer esas tareas mejor que yo.
El director dijo:
“Tengo una petición: cuando vayas a casa hoy, ve y lava las manos de tu padre, y luego ven a verme mañana por la mañana.”

El joven sintió que su oportunidad de conseguir el trabajo era alta.
Cuando regresó a su casa le pidió a su padre que le permitiera lavar sus manos.
Su padre se sintió extraño, feliz pero con sentimientos encontrados y mostró sus manos a su hijo. El joven lavó las manos poco a poco. Era la primera vez que se daba cuenta de que las manos de su padre estaban arrugadas y tenían tantas cicatrices. Algunos hematomas eran tan dolorosos que su piel se estremeció cuando él la tocó.
Esta fue la primera vez que el joven se dio cuenta de lo que significaban este par de manos que trabajaban todos los días para poder pagar su estudio. Los moretones en las manos eran el precio que tuvo que pagar por su educación, sus actividades de la escuela y su futuro.
Después de limpiar las manos de su padre, el joven se puso en silencio a ordenar y limpiar el taller. Esa noche, padre e hijo hablaron durante un largo tiempo.

A la mañana siguiente, el joven fue a la oficina del director.
El director se dio cuenta de las lágrimas en los ojos del joven cuando le preguntó: “¿Puedes decirme qué has hecho y aprendido ayer en tu casa?”
El joven respondió: -”lavé las manos de mi padre y también terminé de asear y acomodar su taller”
“Ahora sé lo que es apreciar, reconocer. Sin mis padres, yo no sería quien soy hoy. Al ayudar a mi padre ahora me doy cuenta de lo difícil y duro que es conseguir hacer algo por mi cuenta. He llegado a apreciar la importancia y el valor de ayudar a la familia.

El director dijo: “Esto es lo que yo busco en mi gente. Quiero contratar a una persona que pueda apreciar la ayuda de los demás, una persona que conoce los sufrimientos de los demás para hacer las cosas, y una persona que no ponga el dinero como su única meta en la vida”. “Estás contratado”.

Ver la ram que consume cada proceso en modo humano

Posted on maig 24th, 2014 by Blackhold

Para ver cuando consume cada proceso/programa de forma entendible, muy útil para identificar rápidamente qué se nos está comiendo la RAM de nuestra maquina.

ps -eo size,pid,user,command --sort -size | awk '{ hr=$1/1024 ; printf("%13.2f Mb ",hr) } { for ( x=4 ; x<=NF ; x++ ) { printf("%s ",$x) } print "" }'

Hálldor Már: Nova Cançó en Inglés

Posted on maig 21st, 2014 by Blackhold

Hálldor Már, un Islandés encisado por la Nova Cançó, versiona temas de Raimon, Jaume Sisa, Serrat y Pau Riba

Hálldor Már – Beautiful Lola

El álbum en spotify: https://play.spotify.com/artist/2hAqpc3KO45yPkERfWqXZV

Pàgina següent »