RedHat Network inaccessible

Ayer me encontré con un problema y tenía que instalar unos paquetes para solucionarlo, pero murphy hizo que la redhat network estuviese inaccesible durante cerca de 4 horas!
En redhat la redhat network o rhn para los amigos, es necesaria para hacer cualquier gestión con los paquetes.

El error que salía en todas las máquinas era de este tipo:

# yum search pdo
Loaded plugins: rhnplugin, security
Traceback (most recent call last):
File “/usr/bin/yum”, line 29, in ?
yummain.user_main(sys.argv[1:], exit_code=True)
File “/usr/share/yum-cli/yummain.py”, line 309, in user_main
errcode = main(args)
File “/usr/share/yum-cli/yummain.py”, line 157, in main
base.getOptionsConfig(args)
File “/usr/share/yum-cli/cli.py”, line 187, in getOptionsConfig
self.conf
File “/usr/lib/python2.4/site-packages/yum/__init__.py”, line 665, in <lambda>
conf = property(fget=lambda self: self._getConfig(),
File “/usr/lib/python2.4/site-packages/yum/__init__.py”, line 254, in _getConfig
self.plugins.run(‘init’)
File “/usr/lib/python2.4/site-packages/yum/plugins.py”, line 179, in run
func(conduitcls(self, self.base, conf, **kwargs))
File “/usr/lib/yum-plugins/rhnplugin.py”, line 111, in init_hook
login_info = up2dateAuth.getLoginInfo()
File “/usr/share/rhn/up2date_client/up2dateAuth.py”, line 219, in getLoginInfo
login()
File “/usr/share/rhn/up2date_client/up2dateAuth.py”, line 186, in login
li = server.up2date.login(systemId)
File “/usr/share/rhn/up2date_client/rhnserver.py”, line 50, in __call__
return rpcServer.doCall(method, *args, **kwargs)
File “/usr/share/rhn/up2date_client/rpcServer.py”, line 204, in doCall
ret = method(*args, **kwargs)
File “/usr/lib64/python2.4/xmlrpclib.py”, line 1096, in __call__
return self.__send(self.__name, args)
File “/usr/share/rhn/up2date_client/rpcServer.py”, line 38, in _request1
ret = self._request(methodname, params)
File “/usr/lib/python2.4/site-packages/rhn/rpclib.py”, line 425, in _request
raise InvalidRedirectionError(
rhn.rpclib.InvalidRedirectionError: HTTPS redirected to HTTP is not supported
[root@sucs332 vmware-tools-distrib]# yum search pdo
Loaded plugins: rhnplugin, security
Traceback (most recent call last):
File “/usr/bin/yum”, line 29, in ?
yummain.user_main(sys.argv[1:], exit_code=True)
File “/usr/share/yum-cli/yummain.py”, line 309, in user_main
errcode = main(args)
File “/usr/share/yum-cli/yummain.py”, line 157, in main
base.getOptionsConfig(args)
File “/usr/share/yum-cli/cli.py”, line 187, in getOptionsConfig
self.conf
File “/usr/lib/python2.4/site-packages/yum/__init__.py”, line 665, in <lambda>
conf = property(fget=lambda self: self._getConfig(),
File “/usr/lib/python2.4/site-packages/yum/__init__.py”, line 254, in _getConfig
self.plugins.run(‘init’)
File “/usr/lib/python2.4/site-packages/yum/plugins.py”, line 179, in run
func(conduitcls(self, self.base, conf, **kwargs))
File “/usr/lib/yum-plugins/rhnplugin.py”, line 111, in init_hook
login_info = up2dateAuth.getLoginInfo()
File “/usr/share/rhn/up2date_client/up2dateAuth.py”, line 219, in getLoginInfo
login()
File “/usr/share/rhn/up2date_client/up2dateAuth.py”, line 186, in login
li = server.up2date.login(systemId)
File “/usr/share/rhn/up2date_client/rhnserver.py”, line 50, in __call__
return rpcServer.doCall(method, *args, **kwargs)
File “/usr/share/rhn/up2date_client/rpcServer.py”, line 204, in doCall
ret = method(*args, **kwargs)
File “/usr/lib64/python2.4/xmlrpclib.py”, line 1096, in __call__
return self.__send(self.__name, args)
File “/usr/share/rhn/up2date_client/rpcServer.py”, line 38, in _request1
ret = self._request(methodname, params)
File “/usr/lib/python2.4/site-packages/rhn/rpclib.py”, line 425, in _request
raise InvalidRedirectionError(
rhn.rpclib.InvalidRedirectionError: HTTPS redirected to HTTP is not supported

Una vez reestablecida la RHN este error no aparecía.

3 Comments

  1. és el que menys m’agrada de fer feina amb RHEL: els repositoris

    és complicat de configurar, necessites llicència per baixar qualsevol actualització, si has de muntar una màquina de proves has de jugar amb les llicències o muntar-te un proxy de paquets semi-legal…

    apart que el suport de RH és discret, per utilitzar llenguatge polític.

    jo només recoman RH per a entorns realment crítics i molt concrets, per a la resta amb CentOS tenc molts menys problemes.

    Respon
  2. Blackhold, tengo el mismo error, pero según comentas en el post, el tema de la RedHat Network se arreglo solo? en mi caso tengo mas servidores pero solo uno me muestra este mismo error al intentar descargar unos paquetes, me puedes decir como lo puedo solucionar, gracias

    Respon

Deixa un comentari

L'adreça electrònica no es publicarà. Els camps necessaris estan marcats amb *

Aquest lloc utilitza Akismet per reduir el correu brossa. Aprendre com la informació del vostre comentari és processada