Lenovo Thinkpad x200 – Debian squeeze

Pues de nuevo otra instalación, y la pereza que da vaciar todos tus ficheros, tratar de no perder ninguno, luego configurar toda la maquina y tal… un rollo, no veas!

Primero de todo comentar que xorg ya no usa el /etc/X11/xorg.conf y grub ya no usa el /boot/grub/menu.lst, así que algunas cosas las vamos a configurar de una forma un poco distinta a anteriores veces.

A continuación una lista de los distintos dispositivos y una breve explicación de configuración (si se requiere).

Teclado: todas las teclas de función funcionan correctamente exceptuando el de encender y apagar la luz.

Para hacer que funcione la luz será necesario instalar el paquete tpb (thinkpad buttons)

# apt-get install tpb

http://forum.soft32.com/linux/Thinkpad-R61-Keys-Debian-Lenny-ftopict470079.html

Teclas multimedia: las teclas bajar y subir el volumen funcionan, pero la de mute no, la tecla thinkvantage se deja sin configurar, para mi comodidad asigno abrir una terminal a esta tecla :)
Para hacer funcionar el botón mute bastará en editar el fichero /etc/grub.d/10_linux y añadir acpi_osi=Linux a la línea que contine $GRUB_CMDLINE_LINUX_DEFAULT de forma que quede así:

“${GRUB_CMDLINE_LINUX} ${GRUB_CMDLINE_EXTRA} ${GRUB_CMDLINE_LINUX_DEFAULT} acpi_osi=Linux”

El scroll (botón del medio y el clitoris o thinkfinger), una de las mejores cosas de este portátil por defecto no funciona, esto antes lo solucionábamos editando el  /etc/X11/xorg.conf, como este fichero no existe, vamos a configurar este comportamiento en el udev.

Crearemos el fichero /etc/udev/rules.d/99_trackpoint.rules con el siguiente contenido:

ACTION!=”add|change”, GOTO=”xorg_trackpoint_end”
KERNEL!=”event*”, GOTO=”xorg_trackpoint_end”
ENV{ID_PATH}!=”platform-i8042-serio-1″, GOTO=”xorg_trackpoint_end”
ENV{x11_options.EmulateWheel}=”1″
ENV{x11_options.EmulateWheelButton}=”2″
ENV{x11_options.XAxisMapping}=”6 7″
ENV{x11_options.Emulate3Buttons}=”0″
LABEL=”xorg_trackpoint_end”

Wifi: intel 5300, funciona correctamente al instalar el paquete firmware-iwlwifi

# apt-get install firmware-iwlwifi

Bluetooth: funciona correctamente

3G/GPS: el sistema detecta la tarjeta pero hay algo que falla, no llega ni a dar señal :( por otra parte el GPS no tengo muy claro de que mi tarjeta tenga esta funcionalidad, mirar el siguiente link para mas información:

http://sourceforge.net/apps/mediawiki/mbm/index.php?title=Main_Page

Sensors: necesario instalar el paquete hddtemp

# apt-get install hddtemp

adicionalmente si usamos gnome podemos instalar el sensors-applet, el cual nos permitirá saber la temperatura de distintos componentes de nuestro ordenador de una forma gráfica.

Sonido: funciona correctamente.

Webcam: una vez conseguí que funcionase con el kernel 2.6.26 pero parece que esta no está soportada desde el kernel 2.6.30 por un problema de compatibilidad, en mi anterior configuración había conseguido hacerla funcionar pero luego se estropeó :P así que a seguir investigando por aquí también!

Lector de tarjetas: mmm que fotos tan chulas las de esta tarde ;) (aka funciona).

Fingerprint: no probado

Modem: no probado

HDAPS (accelerómetro):
http://elf.org/x200-tablet-accelerometer
http://www.thinkwiki.org/wiki/Tp_smapi#Installation_from_source

# apt-get install hdapsd

Suspensión e hibernación: funcionan correctamente, al levantar de una suspensión o hibernación todos los componentes funcionan correctamente.

y de momento todo esto hasta aquí :P

más información: http://www.thinkwiki.org/wiki/Installing_Ubuntu_9.10_%28Karmic_Koala%29_on_a_ThinkPad_X200#GPS

Iré rellendando los huecos que faltan a medida que vaya encontrando la solución…

4 Comments

  1. pues no, no he tenido nunca un x61, aunque lo intenté en el curro :P
    El que tenía antes era un Lenovo 3000 V100.

    Ahora mismo tiene un opensolaris para testear un poco este otro sistema operativo :)

    Respon
  2. Pingback: Lenovo thinkpad X200s – Debian squeeze | Blackhold

  3. muy buen post, pero tengo un problemilla, antes tenia squeeze evolucionado, osea creció desde sid (hace ya mas de 2 años) y en mi antigua configuración yo podía presionar el botón del medio (de los tres del mouse) y el presionado con el trackpoint podía mover las barras de visiones (subir, bajar, izquierda, derecha), ahora no puedo hacerlo y no consigo la forma de reconfigurarlo, tienes algo que me pueda ayudar a solucionar este problemita?

    Respon

Deixa un comentari

L'adreça electrònica no es publicarà. Els camps necessaris estan marcats amb *

Aquest lloc utilitza Akismet per reduir el correu brossa. Aprendre com la informació del vostre comentari és processada